https://stackoverflow.com/questions/50198308/gulp-sass-npm-err-failed-at-the-node-sass4-9-0-install-script

node-sass 설치가 요즘들어 좀 꼬인다. 원인을 찾아보니... node.js 버전이 높으면 package.json 내에 낮은 버전으로 만들어져 있는 node-sass 패키지가 문제를 내는 거 같다.

윈도우의 경우 최신으로 package.json 내용을 수정하면 별 탈 없이 해결되는데... 맥의 경우는 퍼미션 문제를 동반한다. 맥은 sudo를 들이대면 어지간한 문제가 대부분 해결되는데... node-sass는 꼭 그렇지도 않다. 그래서 저번에도 글을 하나 쓰긴했는데.. 이번에는 썩 괜찮은 방법 같지는 않지만 문제해결법을 찾은 거 같다.

링크 하단에 나온 댓글 중에 npm install --unsafe-perm=true 로 package.json을 설치하는 것이다. 나의 경우는 이 방법으로 지긋지긋하게 귀찮던 node-sass 설치 문제에서 벗어났다.


'Coding Life' 카테고리의 다른 글

맥에서 node-sass 설치시 에러 대응  (0) 2018.06.06
gulp-sass node-sass npm 설치시 에러 대응전략  (0) 2018.05.18
근황  (0) 2017.08.08
크롬 har 파일 생성  (0) 2017.02.01
즉시실행 익명함수를 쓰게되는 경우  (0) 2016.10.11
폰트 힌팅  (0) 2016.04.26

+ Recent posts